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I only wish that ordinary people had an unlimited capacity for doing harm; then
they might have an unlimited power for doing good.
—Socrates (469–399 B.C.)

In this lab, Section L2.1 introduces you to various commands in the ProModel
menu. In Section L2.2 we discuss the basic modeling elements in a ProModel
model ﬁle. Section L2.3 discusses some of the innovative features of ProModel.
Section L2.4 refers to a short tutorial on ProModel in a PowerPoint presentation
format. Some of the material describing the use and features of ProModel
has been taken from the ProModel User Guide as well as ProModel’s online help
system.

L2.1 Introduction to the ProModel Menu
In this section we introduce you to the title bar and various actions and commands
in the ProModel menu bar. In subsequent chapters we will use many of these commands in various examples and you will have an opportunity to master them. We
encourage you to use the ProModel’s online help to learn more about all the menu
bar commands.

L2.1.1 The Title and the Menu Bars
The title bar at the top of the screen (Figure L2.1) holds the name of the model document currently being created. Until the document is given a name, the title bar
shows “ProModel”. Once the document is given a title (like Paula’s Production
Shop) in the general information dialog box, the title bar shows “ProModel—
(Paula’s Production Shop).”
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FIGURE L2.1
The title and the menu
bars.

FIGURE L2.2
The File menu.

The menu bar, just below the title bar (Figure L2.1), is used to call up menus,
or lists of tasks. The menu bar of the ProModel screen displays the commands you
use to work with ProModel. Some of the items in the menu, like File, Edit, View,
Tools, Window, and Help, are common to most Windows applications. Others
such as Build, Simulation, and Output provide commands speciﬁc to programming in ProModel. In the following sections we describe all the menu commands
and the tasks within each menu.

L2.1.2 File Menu
The File menu (Figure L2.2) allows the user to open a new model, open an existing model, merge two or more submodels into one, save the current model, and
import models created in earlier versions of ProModel. It also allows you to view
a text version of the model and print either the model text ﬁle or the graphic layout
of the model. The printer setup can be modiﬁed from this menu. Model packages
can be created for distribution to others and can also be installed using this menu.
The last item on this menu allows the user to exit the ProModel environment and
go back to the Windows (XP, Me, 2000, 98, 95, or NT) environment.

L2.1.3 Edit Menu
The Edit menu (Figure L2.3) contains selections for editing the contents of edit
tables and logic windows. The selections available from this menu will change
according to the module from which the Edit menu is selected. The selections also
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FIGURE L2.3

FIGURE L2.4

The Edit menu.

The Build menu.
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vary according to the currently selected window. The Edit menu is active only
when a model ﬁle is open.

L2.1.4 Build Menu
The Build menu (Figure L2.4) consists of all of the modules for creating and editing a model, which include the following basic and optional modules:
Basic Modules
Locations
Entities

Processing
Arrivals

Optional Modules
Path Networks
Resources
Shifts
Cost
Attributes
Variables
Arrays Streams

Macros
Subroutines
Arrival Cycles
Table Functions
User Distributions
External Files
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FIGURE L2.5
General Information dialog box.

In addition, two more modules are available in the Build menu: General Information and Background Graphics.
General Information. This dialog box (Figure L2.5) allows the user to specify
the name of the model, the default time unit, the distance unit, and the graphic
library to be used. The model’s initialization and termination logic can also be
speciﬁed using this dialog box. A Notes window allows the user to save information such as the analyst’s name, the revision date, any assumptions made about the
model, and so forth. These notes can also be displayed at the beginning of a simulation run.
Background Graphics. The Background Graphics module (Figure L2.6) allows
the user to create a unique background for the model using the tools in the graphics editor. An existing background can also be imported from another application
such as AutoCAD.
Generally, most graphics objects are laid out in front of the grid. Large objects as well as imported backgrounds are placed behind the grid.

L2.1.5 Simulation Menu
The Simulation menu (Figure L2.7) controls the execution of a simulation and
contains options for running a model, deﬁning model parameters, and deﬁning
and running scenarios.
ProModel also has an add-on feature: SimRunner.
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FIGURE L2.6
Background Graphics dialog box.

FIGURE L2.7

FIGURE L2.8

FIGURE L2.9

The Simulation menu.

The Output menu.

The Tools menu.

L2.1.6 Output Menu
The Output menu (Figure L2.8) starts the ProModel Output Processor for viewing
model statistics. It also allows the user to view the trace, which was generated during simulation model runtime.

L2.1.7 Tools Menu
The Tools menu (Figure L2.9) contains various utilities as follows:
• Graphics Editor: For creating, editing, and modifying graphic icons.
• Stat::Fit: For ﬁtting empirical distributions to a set of user data.
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• Expression Search: A search-and-replace feature for ﬁnding or replacing
expressions throughout a model.
• Options: The paths for model ﬁles, the graphic library, output results, and
auto saves are speciﬁed in this dialog box. The time between auto saves is
also speciﬁed here.
• Customize: With this utility one can add any tools (viz. Dashboard, MPA,
ProClare, Prosetter, ProStat, or Quick Bar), or any other Windows
executable ﬁles to the Tools Menu.
• QuickBar: QuickBar is a versatile tool that can make your work in
ProModel much faster. It allows you to remove buttons, add custom
ProModel buttons, or add custom buttons launching other applications.

L2.1.8 View Menu
The View menu (Figure L2.10) contains selections for setting up the model viewing environment. These settings are used whenever ProModel is started.
The Zoom submenu (Figure L2.11) allows the model to be displayed from
25 percent magniﬁcation to 400 percent magniﬁcation or any other user-speciﬁed
custom magniﬁcation.
The Layout Settings submenu is shown in Figure L2.12. The grid settings
allow the properties of the grids to be changed. The background and routing path
colors can also be changed using this submenu. The various editing preferences
are shown in the Edit Tables submenu (Figure L2.13).
FIGURE L2.10

FIGURE L2.11

The View menu.

The Zoom menu.
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FIGURE L2.12

FIGURE L2.13

The Layout Settings submenu.

Editing preferences in ProModel.

FIGURE L2.14

FIGURE L2.15

The Window menu.

The Help menu.
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L2.1.9 Window Menu
The Window menu (Figure L2.14) allows you to arrange the windows (or
iconized windows) that are currently displayed on the screen so that all windows
are visible at once. It also lets you bring any individual window to the front of the
display.

L2.1.10 Help Menu
The Help menu (Figure L2.15) accesses the ProModel Online Help System
and provides access to the ProModel Tutorial (getting started). Access to the
PROMODEL Corporation website is also provided here. The index is an alphabetic list of all the help topics in the online help system. The main help topics are
categorized as follows:
•
•
•
•
•
•
•

Common procedures.
Overview of ProModel.
Main menus.
Shortcut menu.
Model elements (entities, resources, locations, path networks, and so on).
Logic elements (variables, attributes, arrays, expressions, and so forth).
Statements (GET, JOIN, and the like).
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• Functions.
• Customer support—telephone, pager, fax, e-mail, online ﬁle transfer,
and so on.
To quickly learn what is new in ProModel Version 6.0, go to the Help →
Index menu and type “new features” for a description of the latest features of the
product.

L2.2 Basic Modeling Elements
In this section we introduce the various basic modeling elements in ProModel. In
Lab 3 you will actually build your ﬁrst ProModel simulation model. The basic
modeling elements in ProModel are
a.
b.
c.
d.

Locations
Entities
Arrivals
Processing

Click Build from the menu bar to access these modeling elements (Figure L2.4).
The ProModel Student Version 6.0 limits the user to no more than 20 locations, ﬁve entity types, ﬁve resource types, ﬁve attributes, and 10 RTI parameters
in a simulation model. If more capability is required for special projects, ask your
instructor to contact the PROMODEL corporation about faculty or network versions of the software.

L2.2.1 Locations
Locations represent ﬁxed places in the system where entities are routed for processing, delay, storage, decision making, or some other activity. We need some
type of receiving locations to hold incoming entities. We also need processing
locations where entities have value added to them. To build locations:
a. Left-click on the desired location icon in the Graphics toolbox. Left-click
in the layout window where you want the location to appear.
b. A record is automatically created for the location in the Locations edit
table (Figure L2.16).
c. Clicking in the appropriate box and typing in the desired changes can
now change the name, units, capacity, and so on. Note that in Lab 3 we
will actually ﬁll in this information for an example model.

L2.2.2 Entities
Anything that a model can process is called an entity. Some examples are parts or
widgets in a factory, patients in a hospital, customers in a bank or a grocery store,
and travelers calling in for airline reservations.
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FIGURE L2.16
The Locations edit screen.

To build entities:
a. Left-click on the desired entity graphic in the Entity Graphics toolbox.
b. A record will automatically be created in the Entities edit table
(Figure L2.17).
c. Moving the slide bar in the toolbox can then change the name. Note that
in Lab 3 we will actually ﬁll in this information for an example model.

L2.2.3 Arrivals
The mechanism for deﬁning how entities enter the system is called arrivals. Entities can arrive singly or in batches. The number of entities arriving at a time is
called the batch size (Qty each). The time between the arrivals of successive entities is called interarrival time (Frequency). The total number of batches of arrivals
is termed Occurrences. The batch size, time between successive arrivals, and total
number of batches can be either constants or random (statistical distributions).
Also, the ﬁrst time that the arrival pattern is to begin is termed First Time.
To create arrivals:
a. Left-click on the entity name in the toolbox and left-click on the location
where you would like the entities to arrive (Figure L2.18).
b. Enter the various required data about the arrival process. Note that in
Lab 3 we will actually ﬁll in this information for an example model.
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FIGURE L2.17
The Entities edit table.

FIGURE L2.18
The Arrivals edit table.

L2.2.4 Processing
Processing describes the operations that take place at a location, such as the
amount of time an entity spends there, the resources it needs to complete processing, and anything else that happens at the location, including selecting an entity’s
next destination.
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FIGURE L2.19
The Process edit table.

To create processing we need to do the following:
a. Left-click on the entity name in the toolbar and then left-click on the
desired beginning location (Figure L2.19).
b. Left-click on the destination location. A processing record is created.
c. To add multiple routing lines to the same record, left-click on the Add
Routing button in the toolbox.
d. To route the part to exit, left-click on the Route to Exit button in the
toolbox. Note that in Lab 3 we will actually ﬁll in this information for an
example model.

L2.3 Innovative Features in ProModel
In this section we describe some of the innovative features in ProModel. These
features help automate the model-building process, eliminate the need to remember command syntax, and all but eliminate unintentional errors.

L2.3.1 Logic Builder
The Logic Builder (Figure L2.20) is a tool that makes it easier to create valid logic
statements without having to remember keywords, syntax, required arguments, or
model element names. It takes you through the process of creating statements or
expressions, as well as providing point-and-click access to every element deﬁned
in your model. The Logic Builder knows the syntax of every statement and function, allowing you to deﬁne logic simply by ﬁlling in the blanks.
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FIGURE L2.20
The Logic Builder tool
menu.

When the Logic Builder is open from a logic window, it remains on the screen
until you click the Close button or close the logic window or table from which it
was invoked. This allows you to enter multiple statements in a logic window and
even move around to other logic windows without having to constantly close and
reopen the Logic Builder. However, the Logic Builder closes automatically after
pasting to a ﬁeld in a dialog box or edit table or to an expression ﬁeld because you
must right-click anyway to use the Logic Builder in another ﬁeld.
You can move to another logic window or ﬁeld while the Logic Builder is still
up by right clicking in that ﬁeld or logic window. The Logic Builder is then reset
with only valid statements and elements for that ﬁeld or window, and it will paste
the logic you build into that ﬁeld or window. Some of the commonly used logic
statements available in ProModel are as follows:
•

WAIT:

Used for delaying an entity for a speciﬁed duration at a location,
possibly for processing it.
• STOP: Terminates the current replication and optionally displays a message.
• GROUP: Temporarily consolidates a speciﬁed quantity of similar entities
together.
• LOAD: Temporarily attaches a speciﬁed quantity of entities to the current
entity.
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INC:

Increments a variable, array element, or attribute by the value of a
speciﬁed numeric expression.
UNGROUP: Separates entities that were grouped using the GROUP statement.
MOVE: Moves the entity to the end of the queue in the speciﬁed time.
VIEW: Changes the view of the layout window.
GRAPHIC: Changes the entity’s current picture (graphic).
IF THEN ELSE: Executes a block of statements if the condition is true.
WAIT UNTIL: Delays the processing of the current logic until the condition
is true.
MOVE FOR: Moves the entity to the next location, in the speciﬁed time.
SPLIT: Splits the entity into a speciﬁed number of entities.
PAUSE: Causes the execution of simulation to pause until the user selects
the Resume option.

L2.3.2 Dynamic Plots
Dynamic plots enable you to graphically observe and record statistical information about the performance of model elements during run time. When the simulation model is running, it needs to be paused (Simulation → Pause Simulation).
With the model in the pause mode select Dynamic Plots → New from the Information menu as in Figure L2.21.
The dynamic plots dialog contains a factors list, four panels, and several button controls. The factors list (Figure L2.22) provides each of the available model
factors from your model, and the panels (Figure L2.23) display performance graphs
for the factors you select (ProModel Help, 2001 PROMODEL Corporation).
Button Controls
• Save: Saves a copy of all model data—from the time you start the graphic
display to when you click save—to an Excel spreadsheet.
• Snapshot: Saves a copy of currently displayed, graphed model data to an
Excel spreadsheet.
• Grid: Turns the main panel grid lines on and off.
• Multi-line: Displays a combined graph of panels 1, 2, and 3.
• Refresh: Redraws the graph.
FIGURE L2.21
Dynamic Plots menu.
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Dynamic Plot edit
table.

FIGURE L2.23
Dynamic Plot of the
current value of WIP.
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Right-Click Menus
The right-click menu for the graphic display is available for panels 1, 2, and 3, and
the main panel. When you right-click in any of these panels, the right-click menu
appears.
Panels 1, 2, and 3
• Move Up: Places the graph in the main panel.
• Clear Data: Removes the factor and its graph from panel 1, 2, or 3 and
the main panel. If you created a multi-line graph, Clear Data removes
the selected line from the graph and does not disturb the remaining graph
lines.
• Line Color: Allows you to assign a speciﬁc line color to the graph.
• Background Color: Allows you to deﬁne a speciﬁc background color for
panels 1, 2, and 3.
Main Panel
• Clear All Data: Removes all factors and graphs from panels 1, 2, 3, and
the main panel.
• Remove Line 1, 2, 3: Deletes a speciﬁc line from the main panel.
• Line Color: Allows you to assign a speciﬁc line color to the graph.
• Background Color: Allows you to deﬁne a speciﬁc background color for
panels 1, 2, and 3.
• Grid Color: Allows you to assign a speciﬁc line color to the grid.

L2.3.3 Customize
Customize
You can add direct links to applications and ﬁles right on your ProModel toolbar.
Create a link to open a spreadsheet, a text document, or your favorite calculator
(Figure L2.24).
To create or modify your Custom Tools menu, select Tools → Customize
from your ProModel menu bar. This will pull up the Custom Tools dialog window.
The Custom Tools dialog window allows you to add, delete, edit, or rearrange the
menu items that appear on the Tools drop-down menu in ProModel.

L2.3.4 Quick Bar
Overview
QuickBar is a versatile tool that can make your work in ProModel much faster
(Figure L2.25). This tool is similar to the Windows Taskbar. You can move the bar
around your screen or dock it on one side. Each button on the toolbar resembles
an associated action in ProModel. You can jump straight to the Build Locations
module, or open a new model with the click of a button.
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FIGURE L2.24
Adding Calculator to the Customized Tools menu.

FIGURE L2.25
The QuickBar task bar.

QuickBar is fully customizable. QuickBar allows you to remove buttons, add
custom ProModel buttons, or add custom buttons launching other applications
(ProModel Help, 2001 PROMODEL Corporation).
System Button
Selecting the System button brings up a menu with the following options:
• Auto-Hide: The Auto-Hide feature is used when QuickBar is in the
docked state. If docked, and the Auto-Hide is on, QuickBar will shrink, so
that only a couple of pixels show. When your pointer touches these visible
pixels, the QuickBar will appear again.
• Docking Position: The Docking Position prompt allows you to “dock” the
QuickBar along one side of your screen, or leave it ﬂoating.
• Customize: Access the customize screen by clicking the System button,
then choose “Customize. . . .” Once in the Customize dialog, you can add
or remove toolbars, add or remove buttons from the toolbars, show or
hide toolbars, or move buttons up or down on the toolbar.
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• About: The About option will display information about QuickBar.
• Close QuickBar: The Close QuickBar option will close QuickBar, but
will not change any customizing you may have made to QuickBar.

L2.4 A Tutorial on ProModel 6.0
A tutorial on ProModel is included in the accompanying CD along with the
ProModel software (Figure L2.26). Click on the lower right button to run the
ProModel tutorial. Microsoft PowerPoint is needed to view the tutorial.
This tutorial is meant to familiarize the user with various features of ProModel and its strengths. The ﬁle named tutorial.ppt is in a PowerPoint presentation format and will execute by itself. The tutorial takes approximately 20 minutes
to run and is divided into 10 major steps. Slides for each of the 10 steps also
include animation that shows the model-building process clearly:
1.
2.
3.
4.
5.

FIGURE L2.26
Tutorial on ProModel.

Start new model
Background graphic
Locations
Entities
Path networks
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6.
7.
8.
9.
10.

Resources
Processing
Arrivals
Run simulation
View output

L2.5 Exercises
1. Identify the ProModel menu where you will ﬁnd the following items:
a. Save As
b. Delete
c. View Trace
d. Shifts
e. Index
f. General Information
g. Options
h. Printer Setup
i. Processing
j. Scenarios
k. Tile
l. Zoom
2. Which of the following is not a valid ProModel menu or submenu item?
a. AutoBuild
b. What’s This?
c. Merge
d. Merge Documents
e. Snap to Grid
f. Normal
g. Paste
h. Print Preview
i. View Text
3. Some of the following are not valid ProModel element names. Which ones?
a. Activities
b. Locations
c. Conveyors
d. Queues
e. Shifts
f. Station
g. Server
h. Schedules
i. Arrivals
j. Expressions
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k. Variables
l. Create
What are some of the valid logic statements used in ProModel?
What are some of the differences between the following logic
statements:
a. Wait versus Wait Until.
b. Move versus Move For.
c. Pause versus Stop.
d. View versus Graphic.
e. Split versus Ungroup.
Describe the functions of the following items in the ProModel Edit menu:
a. Delete
b. Insert
c. Append
d. Move
e. Move to
f. Copy Record
g. Paste Record
Describe the differences between the following items in the ProModel
View menu:
a. Zoom vs. Zoom to Fit Layout
b. Show Grid vs. Snap to Grid

